Ticket #545 (closed defect: fixed)

Opened 10 years ago

Last modified 3 months ago

Handle nameserver that (incorrectly) returns DNS RCODE 2/5/9 for DNS SRV query

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: Known-Issues-and-Ideas
Component: pjlib-util Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported: no

Description

Martin wrote:

First an SRV-query is sent; if this query fails an A-query is sent. The problem is that if the SRV-query is responded with RCODE 2 ,5 or 9, the DNS server will be marked as “Bad” and no A-query will be sent. In some senses this might seem reasonable, because with such an answer one could think that the DNS server is not working On the other hand, practical usage has shown that some DNS servers answers these codes on SRV-queries they can not answer – hence the A-query will never be sent and no lookup take place.

A solution probably is to mark the nameserver as bad only after we receive N consecutive errors.

Change History

comment:1 Changed 3 months ago by nanang

  • Status changed from new to closed
  • Resolution set to fixed
  • Backported unset

TeluuCon? 2018: In r5437, RCODE 2 (ServFail?) will not cause server to be marked bad.

Note: See TracTickets for help on using tickets.