Ticket #544 (closed defect: fixed)

Opened 9 years ago

Last modified 9 years ago

RTP/AVP/SAVP negotiation on UPDATE/re-INVITE

Reported by: bennylp Owned by: nanang
Priority: normal Milestone: release-0.9.0
Component: pjsua-lib Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

Case:

  • Caller is using RTP/SAVP, callee is using RTP/AVP
  • Call establishment should be okay, callee will adjust to RTP/SAVP
  • But when callee sends UPDATE, it sends it with RTP/AVP, which will be rejected by caller since it expects RTP/SAVP

Change History

comment:1 Changed 9 years ago by bennylp

Note:

we can use 150_srtp_1_2.py test script to reproduce/test the problem

comment:2 Changed 9 years ago by nanang

  • Status changed from new to closed
  • Resolution set to fixed

In r2032: updated SRTP transport to 'remember' remote transport type preference. (checked in along with major updates on offer/answer scenarios)

Note: See TracTickets for help on using tickets.