Opened 13 years ago

Closed 13 years ago

#251 closed defect (fixed)

Memory leak problem with Symbian

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: Symbian-trunk-integration
Component: pjsip Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description (last modified by bennylp)

Report:

I am suspecting that PjSip has two memory leaks in INVITE
transactions when PjSip is the UAC.

(1) One leak seems to be from
pjsip_endpt_create_request_from_hdr(), called from
pjsip_endpt_create_ack() - that is when constructing ACK for
3xx-6xx final response.

(2) Another leak seems to be when allocating a buffer in
mod_on_tx_msg(). This buffer never seems to be removed.

Change History (4)

comment:1 Changed 13 years ago by bennylp

  • Description modified (diff)

comment:2 Changed 13 years ago by bennylp

  • Resolution set to worksforme
  • Status changed from new to closed

Couldn't reproduce with trunk.

comment:3 Changed 13 years ago by bennylp

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Reopen, detected leaks with UHEAP_MARK/UHEAP_MARKEND

comment:4 Changed 13 years ago by bennylp

  • Resolution set to fixed
  • Status changed from reopened to closed

It was caused by missing CloseSTDLIB(). Ticket closed (again).

Note: See TracTickets for help on using tickets.