Opened 13 years ago

Closed 13 years ago

#252 closed defect (fixed)

Route header issues on Symbian

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: Symbian-trunk-integration
Component: pjsip Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

When adding Route-header to the outgoing request, registration and dialling is working fine, but the stack crashes when cancelling an invite before the other peer answers.


Last print out is:

2007-04-20 09:12:50.638  09:12:50.055     endpoint Request msg CANCEL/cseq=1593183045 (tdta0x765870) created.

When making a print_on of the hdr in sip_util.c:598 then the value is correct.


And the crash is in pjsip_endpt_create_cancel method, here follows the call stack:

sip_util.c:600 pjsip_msg_add_hdr
sip_msg.c:451 pjsip_hdr_clone
sip_msg.c:1475 init_hdr
print_util.h:109 hdr->type = htype;

Change History (1)

comment:1 Changed 13 years ago by bennylp

  • Resolution set to fixed
  • Status changed from new to closed

Unable to reproduce with trunk, closing ticket.

Note: See TracTickets for help on using tickets.