Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#1459 closed defect (fixed)

Assertion when making call to any destination with unresolved host name (thanks Curt Sampson for the report)

Reported by: nanang Owned by: bennylp
Priority: normal Milestone: release-2.0-rc
Component: pjsua-lib Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description (last modified by nanang)

The original report can be found here.

When I make a call to a SIPS URI with a host part that resolves to an
IP address, albeit one with nobody listening for SIP connections on it,
the program fails in the appropriate manner. However, when I make a call
with a SIPS URI that does not resolve in DNS (i.e., there's no A or any
other type of record for it), the program instead dies due to an ABRT
(6) signal, which appears to be due to the following assertion failure:

 ../src/pj/os_core_unix.c:1201: pj_mutex_lock: Assertion `mutex' failed.

Easily reproduced by making a call to any unresolved destination or via unresolved proxy without specifying DNS server and without STUN/ICE (synchronous media channel init).

Change History (2)

comment:1 Changed 8 years ago by nanang

  • Resolution set to fixed
  • Status changed from new to closed

(In [3965]) Fix #1459: returned back the old/1.x way of controlling dialog lifetime in pjsua_call_make_call().

comment:2 Changed 8 years ago by nanang

  • Description modified (diff)
Note: See TracTickets for help on using tickets.