Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1460 closed defect (fixed)

Call may be wrongly hung up if UPDATE is sent to lock codec during early media (thanks Bogdan Krakowski for the report)

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-1.14
Component: pjsip Version: common
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description (last modified by bennylp)

Call will be hung up by PJSIP on the following scenario:

 (1) INVITE (sdp) ----->
 (2)              <-----  183 Progress (sdp with multiple codec list)
 (3)       UPDATE ----->
 (4)              <-----  200 OK/INVITE
 (5)          ACK ----->

With the above scenario, PJSIP will send BYE after step 5 because it detects that an SDP offer-answer is still in progress when call is answered, even though in this case the initial offer-answer (the one with INVITE) has actually completed and the pending offer-answer is the updated one.

Change History (2)

comment:1 Changed 7 years ago by bennylp

  • Resolution set to fixed
  • Status changed from new to closed

(In [3964]) Fixed #1460: Allow call to transition to CONFIRMED state even when SDP negotiation is pending if the pending negotiation is an updated offer and not the original one with the INVITE transaction

comment:2 Changed 7 years ago by bennylp

  • Description modified (diff)
Note: See TracTickets for help on using tickets.