Ticket #13 (closed enhancement: fixed)

Opened 12 years ago

Last modified 11 years ago

Send RTCP RR if stream is not transmitting RTP packets

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-0.6.0
Component: pjmedia Version: 0.5.10.4
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

The RTCP framework should send RTCP RR when it's not transmitting anything.

Currently the transmission of RTCP was driven by transmission of RTP, so when an endpoint is only actively listening (and not sending anything, although stream direction is send-recv), then no RTCP packet is sent.

Change History

comment:1 Changed 11 years ago by bennylp

  • Priority changed from minor to normal
  • Version set to trunk
  • Milestone changed from unassigned to release-0.7.1

comment:2 Changed 11 years ago by bennylp

  • Version changed from trunk to 0.5.10.4
  • Milestone changed from release-0.7.1 to release-0.6.0

comment:3 Changed 11 years ago by bennylp

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from Send RTCP RR correctly to Send RTCP RR if stream is not transmitting RTP packets

Done in r1447.

The stream now will send RTCP SR or RR, depending on whether it has been transmitting RTP packets during the last interval. So even if the stream is sendrecv, it may transmit RR if it's not transmitting any RTP packets on the last interval. For recvonly streams, only RR will be sent.

FYI, this ticket is duplicate of ticket #377.

Note: See TracTickets for help on using tickets.