Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#377 closed enhancement (fixed)

Support for sending RTCP RR

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-0.8.0
Component: pjmedia Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

This is duplicate of ticket #13 for trunk.

The RTCP framework should send RTCP RR when it's not transmitting anything.

Currently the transmission of RTCP was driven by transmission of RTP, so when an endpoint is only actively listening (and not sending anything, although stream direction is send-recv), then no RTCP packet is sent.

Change History (3)

comment:1 Changed 12 years ago by bennylp

  • Resolution set to fixed
  • Status changed from new to closed

Implemented in r1444.

The pjmedia_rtcp_build_rtcp() function now may create RTCP SR (Sender Report) or RR (Receiver Report) depending on whether the endpoint has been transmitting RTP packets since the last interval.

comment:2 Changed 12 years ago by bennylp

In r1445:
Fixed bug in RTCP fraction_lost calculation: the first RTCP packet always shows positive fraction loss

comment:3 Changed 12 years ago by bennylp

In r1446: Fixed bug in incoming RTCP RR handling because the RTCP packet structure has been changed in r1444

Note: See TracTickets for help on using tickets.