Opened 13 years ago

Closed 13 years ago

#98 closed defect (fixed)

Error binding transports to specific IP in PJSUA-API

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-0.5.10
Component: pjsua-lib Version: 0.5.9
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

When application tries to bind SIP transports to specific IP address, the library will return error even though the IP address is a valid address of the local interface:

pjsua_core.c bind() error: Cannot assign requested address [status=120099]

Thanks Hoi-Ho Chan for reporting this.

Change History (1)

comment:1 Changed 13 years ago by bennylp

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r941.

This was caused by PJSUA-LIB didn't pass the address in host byte order when calling pj_sock_bind_ind().

Note: See TracTickets for help on using tickets.