Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#97 closed defect (fixed)

Bug with URI copying in strict routing handling

Reported by: bennylp Owned by: bennylp
Priority: major Milestone: release-0.5.10
Component: pjsip Version: 0.5.9
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

Ryder Rishel <ryderblue-NO at SPAM-gmail.com> points out bug with URI copying when handling strict-route request. It manifests itself in a double "<<" characters in the Route header of outgoing requests sent by pjsip:

Route: <<sip:pjsip-perf@192.168.2.47:5060;transport=udp>>

Change History (2)

comment:1 Changed 13 years ago by bennylp

  • Resolution set to fixed
  • Status changed from new to closed

The bug is caused by a name-addr of a request target being assigned as the URI of the name-addr of the Route header in pjsip_get_request_addr(), causing multiple name-addr containment.

This has been fixed in r938.

Thanks much Ryder Rishel for investigating and fixing this problem!

comment:2 Changed 13 years ago by bennylp

In r939:

made name_addr handling more robust against possibility of bugs that someone may put another name_addr inside a name_addr, by making pjsip_name_get_uri() calls pjsip_uri_get_uri(nameaddr->uri) rather than just returning nameaddr->uri.

Note: See TracTickets for help on using tickets.