Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#706 closed enhancement (fixed)

Reorganization of Visual Studio 2005 projects to support Windows Mobile targets as well as other build configurations

Reported by: bennylp Owned by: ismangil
Priority: normal Milestone: release-1.2
Component: common Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description (last modified by ismangil)

Included in this work:

New build configurations:

  • Debug-Static
  • Debug-Dynamic
  • Release-Static
  • Release-Dynamic

Addition of Windows Mobile targets:

  • Windows Mobile 6 Standard SDK (aka SmartPhone)
  • Windows Mobile 6 Professional SDK (aka PocketPC)
  • Windows Mobile 5 SmartPhone
  • Windows Mobile 5 PocketPC
  • SmartPhone 2003
  • PocketPC 2003

Change History (20)

comment:1 Changed 11 years ago by bennylp

  • Description modified (diff)

comment:2 Changed 11 years ago by bennylp

In r2430:

  • Part 1 of the work: introduction of Windows Mobile 6 Standard SDK as a new target in the existing VS 2005 projects. Still uses Debug/Release? config only. More targets follow.

comment:3 Changed 11 years ago by bennylp

  • Milestone changed from release-1.1 to release-1.2

comment:4 Changed 11 years ago by ismangil

  • Owner changed from bennylp to ismangil

comment:5 Changed 11 years ago by ismangil

  • Status changed from new to assigned

Work in progress: in r2559 added build configurations Dynamic and Static for Release and Debug for Win32 target.

comment:6 Changed 11 years ago by ismangil

  • Description modified (diff)

comment:7 Changed 11 years ago by ismangil

Work in progress: r2584 made sure all win32 projects got all 6 build configs.

comment:9 Changed 11 years ago by ismangil

This is now tracked on milestone:vs-reorg

comment:10 Changed 11 years ago by ismangil

This is now tracked on milestone:VS-Reorg

comment:11 Changed 10 years ago by nanang

In r2638: Merged branch vs-reorg into trunk:

  • Currently supported platforms are Win32 & WM6 std/pro.
  • Renamed project test_pjsip with pjsip_test, also source directory 'test-pjsip' to 'test'.

comment:12 Changed 10 years ago by nanang

In r2640:

  • Added missing PocketPj?.vcproj.
  • Updated include paths of pjmedia_codec.vcproj.
  • Fixed pjproject-vs8.sln that might cause VS stuck in loading.

comment:13 Changed 10 years ago by nanang

In r2641:

  • Recleaned up configuration manager settings, make sure all platform-config combinations are set up properly.

comment:14 Changed 10 years ago by bennylp

In r2645:

  • removed all currently unsupported platforms such as WM 2003 from all projects and solution, to remove Mixed Platforms which is suspected to have caused VS to hang. These platforms will be re-added again later"

comment:15 Changed 10 years ago by nanang

In r2660: Merged branch vs-reorg2 into trunk:

  • Currently supported platforms are: Win32, WM6 std & pro, WM5 SP & PPC, WM2003 SP & PPC.
  • Added libpjproject into solution, this is a single 'combo' library that bundles all PJSIP libraries.
  • Cleaned up most of compile warnings, note that warning level of libgsmcodec has been reduced from 4 to 3.

comment:16 Changed 10 years ago by nanang

In r2663: Fixed problem in other build settings, i.e: VS6 & GNU Makefile, caused by a modificiation in this ticket (see r2638/trunk or r2626/vs-reorg):

  • Fixed missing files problem in pjsip_test.dsp and pjsip/build/Makefile caused by renamed directory 'test-pjsip' into 'test' (see r2638/trunk or r2626/vs-reorg).
  • Renamed test_pjsip.dsp into pjsip_test.dsp.

comment:17 Changed 10 years ago by bennylp

In r2664:

  • renamed output names from vs8 to vc8 to make it backward compatible
  • fixed build error in Samples-vc.mak for Release configuration

comment:18 Changed 10 years ago by bennylp

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:19 Changed 10 years ago by bennylp

reopened, need to do #801 before closing this

comment:20 Changed 10 years ago by bennylp

In r2669:

  • changed samples output directory to bin/samples/$TARGET
  • exe name is plain exe, not file-$TARGET.exe
Note: See TracTickets for help on using tickets.