Opened 12 years ago

Closed 12 years ago

#280 closed defect (fixed)

Failed scenarios with CANCEL requests (thanks Esbjörn Dominique)

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-0.6.0
Component: pjsip Version: 0.5.10.4
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

Two failed CANCEL scenarios were found:

  1. INVITE is sent, and gets challenged with 407. Second INVITE will be sent automatically, but CANCEL will be sent with CSeq equal to the first INVITE.
  2. INVITE is sent, CANCEL is sent. But when 407 is received, second INVITE will still automatically be sent.

Change History (2)

comment:1 Changed 12 years ago by bennylp

  • Milestone changed from release-0.7.0-rc2 to release-0.6.0
  • Version changed from trunk to 0.5.10.4

comment:2 Changed 12 years ago by bennylp

  • Resolution set to fixed
  • Status changed from new to closed

The second issue has been fixed with r1286.
Could not reproduce the first issue.

Note: See TracTickets for help on using tickets.