Ticket #2006 (closed enhancement: fixed)

Opened 2 months ago

Last modified 2 months ago

Android build fail when using NDK r14 caused by the removal of android_alarm.h

Reported by: riza Owned by: bennylp
Priority: normal Milestone: release-2.7
Component: pjlib Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported: no

Description

Since #1961 pjsip use ANDROID_ALARM_GET_TIME for timestamp. However NDK r14 no longer support this by removing android_alarm.h. This patch will detect the android_alarm.h, and if it wasn't found ,timestamp will use CLOCK_BOOTTIME instead.

Change History

comment:1 Changed 2 months ago by riza

  • Status changed from new to closed
  • Resolution set to fixed

In 5574:

Fix #2006: Fix android build failed using NDK r14 caused by by the removal of android_alarm.h.

Note: See TracTickets for help on using tickets.