Ticket #1945 (closed defect: fixed)

Opened 8 months ago

Last modified 2 months ago

Miscellaneous fixes

Reported by: nanang Owned by: bennylp
Priority: normal Milestone: release-2.6
Component: common Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported: no

Description

Miscellaneous updates and fixes

Change History

comment:1 Changed 8 months ago by nanang

In 5397:

Misc (re #1945): Updated array limit checks and docs in pjsip_evsub_register_pkg() and pjsip_endpt_add_capability(). Thanks Alexei Gradinari for the patch.

comment:2 Changed 8 months ago by nanang

In 5398:

Misc (re #1945): Fixed assertion when outgoing call without SDP is answered with 200 also without SDP (on NDEBUG mode, assertion shouldn't occur and call is disconnected immediately).

comment:3 Changed 8 months ago by nanang

In 5399:

Misc (re #1945): Updated ffmpeg video device to query supported format from the device/ffmpeg instead of hardcoded to RGB24.

comment:4 Changed 8 months ago by nanang

In 5400:

Misc (re #1945): Updated checks in pjsip_tx_data_dec_ref(). Thanks Alexei Gradinari for the feedback and the patch.

comment:5 Changed 8 months ago by riza

In 5402:

Re #1945 (misc): Add pjsua2 sample app using javafx.

comment:6 Changed 8 months ago by ming

In 5403:

Re #1945 (misc): Set IPv6 sockets to be IPv6 only

Auto-detect in configure script if this option is supported, and if yes, Set IPv6 sockets to be IPv6 only.

Thanks to Alexander Traud for the patch.

comment:7 Changed 8 months ago by ming

In 5404:

Re #1945 (misc): Fixed missing doxygen group doc for SIP transport TCP.

Thanks to Alexander Traud for the patch.

comment:8 Changed 8 months ago by ming

In 5408:

Re #1945 (misc): Fixed incorrect SRTP crypto suite name and doc.

Thanks to Alexander Traud for the patch.

comment:9 Changed 7 months ago by nanang

In 5421:

Misc (re #1945): Added PJ_HAS_IPV6 in pj_dump_config(), thanks Alexei Gradinari for the suggestion, also updated the year in copyright line.

comment:10 Changed 7 months ago by nanang

In 5422:

Misc (re #1945): Added opus.h/c to VS2005 & VS2015 project pjmedia-codec (thanks Arkadiusz Wronski for the report).

comment:11 Changed 7 months ago by nanang

In 5423:

Misc (re #1945): fixed STUN server resolution should be retried, as PJSUA_STUN_RETRY_ON_FAILURE is set, in media transport creation after the one in startup failed (thanks Marcus Froeschl for the report).

comment:12 Changed 6 months ago by nanang

In 5437:

Misc (re #1945): Updated resolver behaviour to not mark nameserver as bad after responding with PJ_DNS_RCODE_SERVFAIL. Thanks George Joseph for the feedback and the patch.

comment:13 Changed 6 months ago by nanang

In 5440:

Misc (re #1945): Fixed warning in OpenH264 encoder "ParamValidationExt?(), slice mode = SM_SIZELIMITED_SLICE..." (thanks Carlos Dom for the report).

comment:14 Changed 6 months ago by nanang

In 5441:

Misc (re #1945): Added feature of listing dshow device in ffmpeg video device (experimental).

comment:15 Changed 6 months ago by ming

In 5450:

Re #1945 (misc): Fixed incorrect usage of pj_memcmp()

comment:16 Changed 6 months ago by ming

In 5451:

Re #1945 (misc): Fixed wrong parameter caused by previous commit r5450

comment:17 Changed 6 months ago by ming

In 5452:

Re #1945 (misc): Fixes a memory leak in alsa_factory_refresh().

Thanks to Kal (b17 c0de) for the patch.

comment:18 Changed 6 months ago by riza

In 5458:

Re #1945 (misc): Use localtime_r() instead of localtime() (if available) since localtime() is not thread safe.
This fixes a data race in pj_time_decode() which is called from multiple threads.
Thanks to Kal (b17 c0de) for the patch.

comment:19 Changed 6 months ago by ming

In 5461:

Re #1945 (misc): Get rid of 64-bit compiler warnings for pjsua_app

comment:20 Changed 5 months ago by nanang

In 5464:

Misc (re #1945): Fixed assertion in resolver: on read error, source address may be invalid and printing source address will trigger assertion (due to invalid address family).

comment:21 Changed 5 months ago by nanang

In 5466:

Misc (re #1945): Fixed false error message "cannot find Account.." when deleting PJSUA2 Account (thanks Kal for the report).

comment:22 Changed 5 months ago by nanang

In 5467:

Misc (re #1945): Updated SIP URI in sample app pjsua2_demo.cpp (for debugging convenience).

comment:23 Changed 5 months ago by nanang

In r5468:

Avoid calling memchr() or memcpy() with NULL pointer (thanks Kal from the patch).

comment:24 Changed 4 months ago by ming

In 5480:

Re #1945 (misc): Disable local host resolution (PJ_GETHOSTIP_DISABLE_LOCAL_RESOLUTION) for macOS as well (instead of for iOS only).
Please refer to #1342 for more details.

Thanks to Jeff Anderson for the report and the fix.

comment:25 Changed 4 months ago by ming

In 5484:

Re #1945 (misc): Normalize account config's unregistration timeout when adding account.

Thanks to Johan Lantz for the report.

comment:26 Changed 4 months ago by ming

In 5486:

Re #1945 (misc): Revert r5484, unreg_timeout can be zero.

comment:27 Changed 4 months ago by riza

In 5489:

Re #1945: Change the error message on pjsua_media_channel_update() when unknown/unsupported media type is found.

comment:28 Changed 3 months ago by nanang

In 5499:

Misc (re #1945 and re #1954): Export TARGET_ABI to env var in configure-android script. This var is needed by configure script to generate WebRTC source list for Android when "--use-ndk-cflags" is specified.

comment:29 Changed 3 months ago by nanang

In 5500:

Misc (re #1945): Update SRTP to restart crypto tag from 1 when generating reoffer.

comment:30 Changed 3 months ago by nanang

In 5501:

Misc (re #1945): Fixed various compile warnings.

comment:31 Changed 3 months ago by nanang

In 5504:

Misc (re #1945): Creates pjsip-apps/src/swig/java/output automatically in SWIG Java Makefile, as sometime an empty folder is omitted by git (thank you Oliver Wigley for the report).

comment:32 Changed 3 months ago by nanang

In 5505:

Misc (re #1945): Creates pjsip-apps/src/swig/android/app/src/main/jniLibs/armeabi automatically in SWIG Java Makefile, as sometime an empty folder is omitted by git.

comment:33 Changed 3 months ago by nanang

In 5509:

Misc (re #1945): Fixed WebRTC build failure for mips64 platform (thanks Oliver Wigley for the report).

comment:34 Changed 3 months ago by nanang

In 5516:

Misc (re #1945): Fixed warning of missing braces in nested struct/union var initialization on recent GCC versions.

comment:35 Changed 3 months ago by nanang

In 5523:

Misc (re #1945): Fixed bug in NAT detect: missing address family assignment in socket binding (thanks Howard Chalkley for the report).

comment:36 Changed 2 months ago by ming

In 5524:

Re #1945 (misc): move default setting of number of supported video device format to pjmedia-videodev config instead of config_site_sample, since not everybody will use the sample.

comment:37 Changed 2 months ago by ming

In 5525:

Re #1945 (misc): Fixed occasional crash in pjsua Android sample app when initializing OpenGL renderer (crash in init_opengl()->ANativeWindow_setBuffersGeometry()). It doesn't happen in pjsua2 sample app.

comment:38 Changed 2 months ago by ming

In 5527:

Re #1945 (misc): Add an alias REQUESTED-ADDRESS-FAMILY (which is used in the RFC 6156) for REQUESTED-ADDRESS-TYPE (which is used in the draft). Change the string literal to use the RFC version.

comment:39 Changed 2 months ago by nanang

In 5530:

Misc (re #1945): Added TLS transport in pjsua2 sample app.

comment:40 Changed 2 months ago by nanang

In 5531:

Misc (re #1945): re r5530, reset SIP transport port setting to SIP_PORT before saving the configs.

comment:41 Changed 2 months ago by riza

In 5536:

Re #1945 (misc): Don't trigger SRV complete callback when there is a parse error.

comment:42 Changed 2 months ago by ming

In 5542:

Re #1945 (misc): On iOS, print log in debugging console output when using ipjsua with cli.

comment:43 Changed 2 months ago by nanang

In 5544:

Misc (re #1945): Fixed compile warnings on Android 64bit platforms, e.g: dereferencing type-punned pointer, using uninitialized var.

comment:44 Changed 2 months ago by riza

In 5545:

Re #1945 (misc): Prevent automatically adding Content-Type and Content-Length on
printing multipart data when its already printed.

comment:45 Changed 2 months ago by nanang

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.