Opened 4 years ago

Closed 3 years ago

Last modified 2 years ago

#1882 closed defect (fixed)

Miscellaneous fixes

Reported by: ming Owned by: bennylp
Priority: normal Milestone: release-2.5
Component: common Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported: no

Description

Miscellaneous updates and fixes.

Change History (67)

comment:1 Changed 4 years ago by ming

In 5171:

Re #1882 (misc): In iOS, set the option to notify other apps upon audio session deactivation. This will be useful so other apps can return to active state and resume its audio.

Thanks to Johan Lantz for the patch.

comment:2 Changed 4 years ago by nanang

In 5176:

Misc (re #1882): Update doxygen of PJSIP_MAX_URL_SIZE as apparently it is currently much more than for logging purpose, e.g: restricting Contact header length (thanks Marcus Froeschl for the feedback).

comment:3 Changed 4 years ago by ming

In 5179:

Re #1882 (misc): Related to r4852 and r4857, fixed problem in reopening sound device after setting it to null device

Thanks to Fredrik Hansson for the report and patch

comment:4 Changed 3 years ago by ming

In 5187:

Re #1882 (misc): Fixed possibly incorrect stream stats

When a codec is opened, it can modify its param (such as iLBC can normalize its frame ptime based on remote SDP), so the stream stats has to be updated accordingly.

Also in this fix is to increase the log level which shows the info of iLBC mode opened.

comment:5 Changed 3 years ago by nanang

In 5189:

Misc (re #1882): Updated libresample makefile to also generate shared library when configure param '--enable-resample-dll' (see also #1462) is specified.

comment:6 Changed 3 years ago by nanang

In 5190:

Misc (re #1882): Added array length check before inserting parsed bandwidth & attribute info to SDP structure (thanks Fredrik Hansson for the patch).

comment:7 Changed 3 years ago by nanang

In 5191:

Misc (re #1882): Only check 'hide' URI parameter on SIP/SIPS URIs in printing route header, otherwise it may cause crash as other URI types may not have 'other_param' field (thanks thanks Fredrik Hansson for the patch).

comment:8 Changed 3 years ago by ming

In 5192:

Re #1882 (misc): Fixed inaccurate index checking assertion when removing SDP attributes in pjmedia_sdp_attr_remove() and pjmedia_sdp_attr_remove_all()

Thanks to Fredrik Hansson for the report.

comment:9 Changed 3 years ago by ming

In 5193:

Re #1882 (misc): related to r5192, fixed inaccurate index checking in pjmedia_sdp_attr_find() as well

comment:10 Changed 3 years ago by ming

In 5201:

Re #1882 (misc): Configurable audio device name length

Thanks to Wolfgang Wallhäuser for the original patch.

comment:11 Changed 3 years ago by riza

In 5202:

Re #1882 (misc): Fix bug in parser,which may loop infinitely when it doesn't fine the required character.
Thanks to Oleg Grazhdan for the patch.

comment:12 Changed 3 years ago by nanang

In 5203:

Misc (re #1882): Added include header guard to pjnath.h.

comment:13 Changed 3 years ago by nanang

In 5204:

Misc (re #1882): Need to zero-fill pj_thread_desc in libRegisterThread() to avoid assertion in pj_thread_register() due to accidentally recognized as reused descriptor.

comment:14 Changed 3 years ago by nanang

In 5206:

Misc (re #1882): Added feature of CDATA content handling into XML parser.

comment:15 Changed 3 years ago by ming

In 5207:

Re #1882 (misc): Fixed bug in SipTransaction::fromPj(pjsip_transaction &) which do not copy the state variable

comment:16 Changed 3 years ago by ming

In 5209:

Re #1882 (misc): Fixed uninitialized mainThreadOnly variable in UaConfig

Last edited 3 years ago by ming (previous) (diff)

comment:17 Changed 3 years ago by ming

In 5212:

Re #1882 (misc): Removed unnecessary callback setting for TLS listeners

comment:18 Changed 3 years ago by ming

In 5213:

Re #1882 (misc): Fixed configure-android shell script error on Linux

comment:19 follow-up: Changed 3 years ago by riza

In 5215:

Re #1882 (misc): Check for duplicate entry when building list of ICE host candidate. Thanks to Dusan Klenic for the original patch.

comment:20 Changed 3 years ago by nanang

In 5216:

Misc (re #1882): Fixed wrong specifier used in ssl_sock_ossl.c (should be 'PJ_DEF' instead of 'PJ_DECL').

comment:21 Changed 3 years ago by nanang

In 5217:

Misc (re #1882): Fixed bug STUN still being used in media transport UDP & ICE after STUN is disabled in account config (media_stun_use == PJSUA_STUN_USE_DISABLED).

comment:22 in reply to: ↑ 19 Changed 3 years ago by ming

In 5215:

Re #1882 (misc): Check for duplicate entry when building list of ICE host candidate.

Thanks to Dusan Klinec for the original patch.

Last edited 3 years ago by riza (previous) (diff)

comment:23 Changed 3 years ago by ming

In 5218:

Re #1882 (misc): Fixed missing comma in timer names string array. Thanks to Dusan Klinec for the patch.

comment:24 Changed 3 years ago by ming

In 5219:

Re #1882 (misc): Add checking of crypto name in transport srtp.

Thanks to Dusan Klinec for the patch.

comment:25 Changed 3 years ago by ming

In 5220:

Re #1882 (misc): Fixed incorrect sizeof argument when using pj_bzero() and pj_memcpy() in ssl_sock_ossl.c

Thanks to Dusan Klinec for the patch.

comment:26 Changed 3 years ago by ming

In 5221:

Re #1882 (misc): Fixed potential out-of-bound array access in ice_session.

Thanks to Dusan Klinec for the patch.

comment:27 Changed 3 years ago by ming

In 5222:

Re #1882 (misc): Fixed string truncation length checking in srtp (note that this is a third party source).

Thanks to Dusan Klinec for the patch.

comment:28 Changed 3 years ago by ming

In 5223:

Re #1882 (misc): Moved checking of header count earlier when parsing generic array header in sip_parser.

Thanks to Dusan Klinec for the patch.

comment:29 Changed 3 years ago by ming

In 5224:

Re #1882 (misc): Add checking before calling pj_strncpy(), to make it more robust and consistent with the other two checks below.
Note that without the check, it should be safe, but the buffer could point to one byte after the buffer, even though the string length is zero.

Thanks to Dusan Klinec for the proposed patch.

comment:30 Changed 3 years ago by ming

In 5225:

Re #1882 (misc): re r5222, fixed string truncation length checking (the string is null terminated) in srtp.

Thanks to Dusan Klinec for the patch.

comment:31 Changed 3 years ago by ming

In 5226:

Re #1882 (misc): Fixed incorrect loop when destroying streams in case of non-successful stream creation.

Thanks to Dusan Klinec for the patch.

comment:32 Changed 3 years ago by ming

In 5227:

Re #1882 (misc): Use cred->cnonce instead of cnonce when calling pjsip_auth_create_digest(), since cnonce can be null

Thanks to Dusan Klinec for the patch.

comment:33 Changed 3 years ago by ming

In 5228:

Re #1882 (misc): should check nscount (instead of anscount) when iterating ns values.

Thanks to Dusan Klinec for the patch.

comment:34 Changed 3 years ago by ming

In 5229:

Re #1882 (misc): Add assertion checks in pj_strncpy() and pj_strncpy_with_null(). When max is negative, it may go undetected and cause crash since it will be cast to an unsigned when calling pj_memcpy().

Thanks to Dusan Klinec for the suggestion.

comment:35 Changed 3 years ago by ming

In 5230:

Re #1882 (misc): close socket on error after calling pj_sock_getsockname() as it was closed above on error after calling get_published_name()

Thanks to Dusan Klinec for the patch

comment:36 Changed 3 years ago by ming

In 5231:

Re #1882 (misc): Add checks as ssocket_cli and state_cli can be NULL

Thanks to Dusan Klinec for the original patch.

comment:37 Changed 3 years ago by riza

In 5232:

Re #1882 (misc): Crash when answering call with reason field is set. Thanks to Dan Wright for the report.

comment:38 Changed 3 years ago by nanang

In 5234:

Misc (re #1882): Suppress EAGAIN recv() error log in pjmedia stream.c & vid_stream.c (thanks Christian Ambach for the patch).

comment:39 Changed 3 years ago by riza

In 5237:

Misc (Re #1882): When server sends blank realm on the Authentication challanges, the stack doesn't include the realm param.
And hence, the server will reject the request. This patch will include the blank realm on the next request.
Thanks to Keith Hanaway for the report.

comment:40 Changed 3 years ago by riza

In 5238:

Misc (Re #1882): Add raw certificate information to pj_ssl_cert_info data. Thanks to Peter Koletzki for the suggestion.

comment:41 Changed 3 years ago by nanang

In 5240:

Misc (re #1882): Added exception catch in Call destructor.

comment:42 Changed 3 years ago by riza

In 5242:

Misc (Re #1882): Add compile time option (PJMEDIA_HAS_DTMF_FLASH) to enable/disable DTMF flash as specified in rfc2833.

comment:43 Changed 3 years ago by riza

In 5243:

Misc (Re #1882): When finding a dialog, use normal check for the dialog id instead an assertion check. Thanks for Andrey Kovalenko for the patch.

comment:44 Changed 3 years ago by nanang

In 5244:

Misc (re #1882): Updated log level (from 1 or 2 to 3) for some error messages that are transient, recoverable, or handled with return codes (thanks George Joseph for the patch).

comment:45 Changed 3 years ago by nanang

In r5245: Fixed compile error on VS2005 due to double semicolons.

comment:46 Changed 3 years ago by nanang

In 5247:

Misc (re #1882): Updated ioqueue epoll related vars in build config, e.g: update 'ac_linux_poll' value, introduce PJ_HAS_LINUX_EPOLL flag (thanks George Joseph for the patch).

comment:47 Changed 3 years ago by ming

In 5248:

Re #1882 (misc): Fixed a bug in Android sound device backends which prevent them to create a unidirectional stream

comment:48 Changed 3 years ago by ming

In 5249:

Re #1882 (misc): Various IPv6 fixes:

  • For contact rewrite feature, when contact address is IPv6, it shouldn't be replaced with IPv4 address
  • If tp_type is already of type IPv6, adding it with PJSIP_TRANSPORT_IPV6 will result in an invalid transport type
  • Add check if pj_getaddrinfo() returns zero address.

comment:49 Changed 3 years ago by ming

In 5250:

Re #1882 (misc): Fixed Rseq to start from 1 (instead of from 0).
According to RFC 3262:
... MUST include an RSeq header field. The value

of the header field for the first reliable provisional response in a
transaction MUST be between 1 and 231 - 1.

Thanks to Marcus Froeschl for the report.

comment:50 Changed 3 years ago by nanang

In 5251:

Misc (Re #1882): Fixed crash in sample app encdec.c due to insufficient buffer when using codec with clockrate > 16000Hz.

comment:51 Changed 3 years ago by bennylp

In 5253:

Misc (Re #1882): encdec print the bitrate

comment:52 Changed 3 years ago by nanang

In 5258:

Misc (re #1882): Fixed CLI-telnet log level check in log printing, i.e: log level is by default set to 4, but it didn't print log messages with level 4.

comment:53 Changed 3 years ago by nanang

In 5259:

Misc (re #1882): Fixed crash due to insufficient buffer in printing video device capabilities and formats in pjsua app.

comment:54 Changed 3 years ago by ming

In 5263:

Re #1882 (misc): Fixed library open error on Android when using SDK version 23 and warning: library has invalid DT_NEEDED entry for SDK version below 23

comment:55 Changed 3 years ago by ming

In 5265:

Re #1882 (misc): Fixed crash caused by typo when initializing pjsua_msg_data

comment:56 Changed 3 years ago by riza

In 5275:

Re #1882 (misc): Incorrect use of pjsip_VIA_PARAM_SPEC on sip_parser.c. Thanks to George Joseph for the patch.

comment:57 Changed 3 years ago by riza

In 5276:

Re #1882 (misc): Error raised from aconfigure on CentOS6(autoconf 2.63) related to opencore-amrnb.
Thanks to George Joseph for the patch.

comment:58 Changed 3 years ago by ming

In 5278:

Re #1882 (misc): Add implementation to call Endpoint::onSelectAccount() callback

comment:59 Changed 3 years ago by ming

In 5279:

Re #1882 (misc): Removed extraneous (and possibly inaccurate) log when subscribing/unsubscribing presence in pjsua_pres

comment:60 Changed 3 years ago by ming

In 5280:

Re #1882 (misc): Removed stripping of '[]' from pvalue header parameters.

The stripping of '[]' from header parameters causes issues if
something (like a port) occurrs after the final ']'.

'[2001:a::b]' will correctly parse to '2001:a::b'
'[2001:a::b]:8080' will correctly parse to '2001:a::b' but the scanner is left
with ':8080' and parsing stops with a syntax error.

Thanks to Anthony Messina and George Joseph for the patch.

comment:61 Changed 3 years ago by nanang

In r5281:


Update Python setup.py to get 'make' from environment variable MAKE, if it doesn't exist, just use 'make'. On some systems, such as FreeBSD, default 'make' command is not GNU compatible.


Thanks George Joseph for the patch.

comment:62 Changed 3 years ago by riza

In 5285:

Misc (re #1882): Fixed buffer size not sufficient when setting cipher list.

comment:63 Changed 3 years ago by nanang

In 5287:

Misc (re #1882): Fixed build warning on Android: narrowing conversion of long uint to long int.

comment:65 Changed 3 years ago by ming

In 5291:

Re #1882 (misc): re r5290, wrong value of Enable Bitcode setting, should be NO

comment:66 Changed 3 years ago by nanang

  • Resolution set to fixed
  • Status changed from new to closed

comment:67 Changed 2 years ago by ming

Last edited 2 years ago by ming (previous) (diff)
Note: See TracTickets for help on using tickets.