Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#1462 closed defect (fixed)

Add support for building libresample as shared library for GNU targets

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-1.14
Component: third-party Version: common
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description (last modified by bennylp)

We already have Visual Studio project for building libresample (under third_party) as DLL. This ticket adds similar support for building libresample as shared library for GNU targets and linking with it.

To build the libraries and samples with libresample as shared library:

 $ ./aconfigure --enable-resample-dll
 $ make dep && make

The libresample is placed in third_party/lib, hence don't forget to set LD_LIBRARY_PATH (or DYLD_LIBRARY_PATH on Mac) accordingly before running an executable.

Change History (7)

comment:1 Changed 8 years ago by bennylp

  • Description modified (diff)

comment:2 Changed 8 years ago by bennylp

  • Resolution set to fixed
  • Status changed from new to closed

(In [3967]) Closed #1462: Added support for building libresample as shared library for GNU targets

comment:3 Changed 8 years ago by bennylp

  • Description modified (diff)

comment:4 Changed 8 years ago by bennylp

  • Description modified (diff)

comment:5 Changed 8 years ago by bennylp

(In [3968]) Re #1462: libresample as shared library support on Mac OS X

comment:6 Changed 8 years ago by bennylp

(In [3970]) Re #1462: fixed broken make install caused by previous changes

comment:7 Changed 8 years ago by bennylp

(In [3974]) Re #1462: fixed libresample.dylib.1 installation issue

Note: See TracTickets for help on using tickets.