Opened 6 years ago

Closed 13 months ago

Last modified 10 months ago

#1778 closed enhancement (fixed)

Support for Voice Processing IO Audio Unit on Mac

Reported by: nanang Owned by: nanang
Priority: normal Milestone: release-2.10
Component: pjmedia-audiodev Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported: no

Description (last modified by ming)

Voice Processing IO Audio Unit is considered to provide nice features such as echo cancellation & AGC, it is supported since Mac OSX 10.7.

Our internal testing indicates that the EC performance is far more superior than any software EC. However, VPIO seems to work only with specific devices, thus requiring you to use the default/built-in audio I/O devices (i.e. it doesn't allow you to select your own devices). Application wishing to disable the hardware EC and use software EC instead can specify PJMEDIA_ECHO_USE_SW_ECHO in pjsua_media_config.ec_options (or MediaConfig.ecOptions in pjsua2).

*Limitation: only works in mono. *

Change History (6)

comment:1 Changed 3 years ago by nanang

  • Milestone changed from release-2.x to release-2.9

comment:2 Changed 13 months ago by ming

  • Description modified (diff)

comment:3 Changed 13 months ago by ming

  • Resolution set to fixed
  • Status changed from new to closed

In 6094:

Fixed #1778: Support for Voice Processing IO Audio Unit on Mac

comment:4 Changed 10 months ago by ming

In 6127:

Re #1778: Fixed incorrect calculation for stereo mode

comment:5 Changed 10 months ago by ming

In 6128:

Re #1778: Temporarily disable VPIO on Mac for stereo due to recording sound defects.
Steps to reproduce:

  • Revert this changeset
  • Use pjsua to do sound loopback (cc 0 0) with --ec-tail=0 (VPIO disabled->audio fine) and ec-tail=1 (VPIO enabled->recording sound defects)

Several observations:

  • Playback is totally fine in VPIO stereo mode.
  • Defect more noticable in 44.1 kHz

comment:6 Changed 10 months ago by ming

  • Description modified (diff)
Note: See TracTickets for help on using tickets.