Opened 5 years ago

Closed 5 years ago

#1751 closed defect (fixed)

Miscellaneous fixes

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-2.3
Component: common Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported: no

Description

Miscellaneous updates and fixes.

Change History (47)

comment:1 Changed 5 years ago by bennylp

In 4798:

Misc (re #1751): added experimental option to enable/use worker thread for Python. To enable worker thread:

  • uncomment USE_THREADS in pjsip-apps/src/swig/python/Makefile
  • change USE_THREADS to True in pjsip-apps/src/pygui/application.py

comment:2 Changed 5 years ago by ismangil

In 4799:

Re #1751 Removed reference to libmilenage in ipjsua iOS

comment:3 Changed 5 years ago by riza

In 4800:

Re #1751: Fix build error when using 'disable-libsamplerate' on configure.

comment:4 Changed 5 years ago by nanang

In 4803:

Misc (re #1751): Fixed unremoved pjsua2_demo.o after 'make clean'.

comment:5 Changed 5 years ago by ming

In 4810:

Re #1751 (misc): Add feature in Python API to enable mwi and modify account (thanks to John Bigelow for the patch). This is to update the old API. If possible, application is recommended to use the new API based on pjsua2 instead (please refer to pjsua2 book).

comment:6 Changed 5 years ago by riza

In 4811:

Misc (re #1751): Fixed unintialized field of pjmedia_transport_info.

comment:7 Changed 5 years ago by riza

In 4814:

Misc (re #1751): Fixed compile error on stereo_demo due to changes on pjmedia_port_info.

comment:8 Changed 5 years ago by bennylp

In 4816:

Misc (re #1751): do not update RTCP TX statistic if sending RTP in stream (audio and video) fails

comment:9 Changed 5 years ago by bennylp

In 4818:

Misc re #1751: increase maximum ALSA devices from 16 to 32

comment:10 Changed 5 years ago by nanang

In 4822:

Misc (re #1751): Fixed compile error 'Implicit declaration of function is invalid in C99' on Xcode 5.1.1.

comment:11 Changed 5 years ago by nanang

In 4823:

Misc (re #1751): Set media transport state back to NULL after media transport creation fails, and also remember the error code.

comment:12 Changed 5 years ago by riza

In 4825:

Misc (re #1751): Fix crash when executing pattern matched shortcut on cli.

comment:13 Changed 5 years ago by riza

In 4826:

Misc (re #1751): Fix crash when retrieving dynamic choice(video stream info) caused by the use of invalid array index.

comment:14 Changed 5 years ago by riza

In 4833:

Misc (re #1751): Fix build error (Ubuntu 14.04) when building Pjsip with OpenCore?-AMR.Thanks to Alexander Traud for the patch.

comment:15 Changed 5 years ago by nanang

In 4847:

Misc (re #1751): Fixed build error when PJ_LOG_MAX_LEVEL is set to 0 (thanks Fredrik Hansson for the report).

comment:16 Changed 5 years ago by nanang

In 4849:

Misc (re #1751): Fixed SIP status phrase of status code 484 to be "Address Incomplete" (thanks Graeme Robertson for the report).

comment:17 Changed 5 years ago by nanang

In 4851:

Misc (re #1751): Fixed uninitialized config filename in ui_write_settings() in pjsua app (thanks Lars Helgeson for the report).

comment:18 Changed 5 years ago by nanang

In r4850: Fixed AF_INET should be PJ_AF_INET in sock_common.c (thanks Lars Helgeson for the report).

comment:19 Changed 5 years ago by ming

In 4852:

Re #1751 (misc): Avoid setting sound device if sound devices are the same (thanks to Christian Ambach for the patch)

comment:20 Changed 5 years ago by bennylp

In 4855:

Misc (re #1751): invalidate timer entry for every cancel() scenario to avoid assertion next time the entry is scheduled if cancellation fails (thanks Johan Lantz for the report)

comment:21 Changed 5 years ago by bennylp

In 4856:

Misc (re #1751): added additional checking to invite and dialog instances when terminating the call when media initialization fails due to suspected crash

comment:22 Changed 5 years ago by bennylp

In 4857:

Misc (re #1751): fixed problem in r4852 which caused sound not to be opened

comment:23 Changed 5 years ago by bennylp

In 4858:

Misc (re #1751): fixed error when retrieving SSL error. Thanks Vittorio Giovara for the patch

comment:24 Changed 5 years ago by bennylp

In 4868:

Misc re #1751: removed --tls-srv-name from pjsua usage text since that feature has been removed long time ago by #1448 (thanks Alexander Traud for the patch)

comment:25 Changed 5 years ago by bennylp

In 4870:

Misc re #1751: changing Android java's String.isEmpty() to String.length()==0 for better portability since the former is only available on API level 9

comment:26 Changed 5 years ago by riza

In 4872:

Misc (re #1751): fix crash when receiving unhold message caused by access to invalid data as a result of pool reset (Thanks to Itay Bianco for the report).

comment:27 Changed 5 years ago by nanang

In 4876:

Misc (re #1751): Fixed possible bad assertion caused by race condition between regc_tsx_callback() and pjsip_regc_send() (thanks John Ryan for the report).

comment:28 Changed 5 years ago by nanang

In 4877:

Misc (re #1751): Delete config.log and config.status on "make distclean/realclean".

comment:29 Changed 5 years ago by nanang

In 4878:

Misc (re #1751): Updated configure script to pass params using "$@" (thanks Alexander Traud for the feedback).

comment:30 Changed 5 years ago by nanang

In 4880:

Misc (re #1751): Fixed missing initialization in pjsua2 TlsConfig::toPj() and TransportConfig::toPj() may cause transport creation failure (thanks Sneha Bansal for the report).

comment:31 Changed 5 years ago by ming

In 4883:

Re #1751 (misc): Fixed incorrect usage of dev_size (should be dev_count) in coreaudio device

comment:32 Changed 5 years ago by nanang

In 4884:

Misc (re #1751): Uninitialized variable 'body.tsxState.type' in PJSUA2 in SipEvent::fromPj() (thanks Thomas Steinacher for the report and the fix).

comment:33 Changed 5 years ago by nanang

In 4885:

Misc (re #1751): Remove reference to PJSUA2 Call instance from PJSUA library in PJSUA2 Call destructor regardless the PJSUA state to avoid crash caused by accessing dangling pointer of the Call instance (thanks Thomas Steinacher for the report).

comment:34 Changed 5 years ago by nanang

In 4886:

Misc (re #1751): Bad typo on passthrough codec (thanks Peter Koletzki for the report).

comment:35 Changed 5 years ago by bennylp

In 4890:

Re #1751: fixed miscellaneous gcc warnings

comment:36 Changed 5 years ago by ming

In 4892:

Re #1751 (misc): Fixed compilation error due to the lack of the SSLv2 methods.
The fix will autodetect this and define OPENSSL_NO_SSL2 if necessary. Related to #1321.

(thanks to Walter Doekes for the patch)

Last edited 5 years ago by ming (previous) (diff)

comment:37 Changed 5 years ago by bennylp

In 4893:

Misc, Re #1751: fixed pjsip-test failures

comment:38 Changed 5 years ago by bennylp

In 4894:

Misc re #1751: disable one pjlib-test entry on socket address parsing

comment:39 Changed 5 years ago by riza

In 4896:

Misc (re #1751): fixed sound issue on Android L(using PJMEDIA_AUDIO_DEV_HAS_ANDROID_JNI), caused by the difference in JNI array handling. (Thanks Miguel Penades for the report).

comment:40 Changed 5 years ago by nanang

In r4897: Fixed miscellaneous MSVC warnings.

comment:41 Changed 5 years ago by nanang

In 4898:

Misc (re #1751): fixed occasional failure in pjsip-test & pjnath-test caused by resource leak.

comment:42 Changed 5 years ago by nanang

In 4901:

Misc (re #1751): Suppress compile warnings of OpenSSL deprecation on MacOSX.

comment:43 Changed 5 years ago by nanang

In 4903:

Misc (re #1751): Fixed wrong pointer check in starting video render device.

comment:44 Changed 5 years ago by riza

In 4905:

Misc (re #1751): Avoid confusion caused by double variable declaration. (Thanks Itay Bianco for the report).

comment:45 Changed 5 years ago by riza

In 4910:

Misc (re #1751): fixed printing value issue when using %02X format. (Thanks Itay Bianco for the report).

comment:46 Changed 5 years ago by nanang

In r4912: Change default sound device on Android to use Android JNI (due to stuck issue with OpenSL ES).

comment:47 Changed 5 years ago by nanang

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.