Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1668 closed enhancement (fixed)

Option to use the IP address found in REGISTER response in the SDP

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-2.2
Component: pjsua-lib Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported: no

Description (last modified by bennylp)

pjsua_acc_config.allow_sdp_nat_rewrite:

This option controls whether the IP address in SDP should be replaced with the IP address found in Via header of the REGISTER response, ONLY when STUN and ICE are not used and there is active registration session present. If the value is FALSE (the original behavior, and the default value), then the local IP address will be used. If TRUE, and when STUN and ICE are disabled, then the IP address found in registration response will be used, until the account unregisters, on which the private IP will be used again.

Change History (3)

comment:1 Changed 7 years ago by bennylp

  • Resolution set to fixed
  • Status changed from new to closed

In 4543:

Closed #1668: Option to use the IP address found in REGISTER response in the SDP

comment:2 Changed 7 years ago by bennylp

  • Description modified (diff)

comment:3 Changed 7 years ago by bennylp

In 4544:

Re #1668: fixed silly crash in pjsua_media.c:245 caused by r4543

Note: See TracTickets for help on using tickets.