Opened 7 years ago

Closed 7 years ago

#1667 closed enhancement (fixed)

Handle incoming UPDATE before 101-199 response is received

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-2.2
Component: pjsip Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported: no

Description

The specification does not allow callee to send UPDATE before 101-199 provisional response with a tag is sent. This is because the dialog has not been established before a tag is response, and UPDATE can only be sent on an established dialog (early or confirmed).

Reference: RFC 3261 Section 12.1 and RFC 3311 Section 3

But we receive this anyway. Since we already handle the case when NOTIFY arrives before SUBSCRIBE response, we should tolerate this scenario as well.

Change History (1)

comment:1 Changed 7 years ago by bennylp

  • Resolution set to fixed
  • Status changed from new to closed

In 4521:

Fixed #1667: Handle incoming UPDATE before 101-199 response is received

Note: See TracTickets for help on using tickets.