Ticket #1554 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Assertion in ICE when STUN resolution yields a same address as one of the host candidate and there is only one host candidate exists (thanks Claudio De Angelis for the report)

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-2.1
Component: pjnath Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported: no

Description

This can be reproduced by limiting host candidate to one with "media_cfg.ice_max_host_cands = 1", and setting the STUN server in the same LAN.

This bug was introduced by changeset r4133 for ticket #1512 for milestone:release-2.0.

Also fix another assertion caused by ICE strans that is allowed to run without any candidates. This happens in two situations:

  1. during creation, with host candidates disabled and no STUN/TURN enabled.
  2. during initialization, with host candidates disabled, and STUN resolution yields error, and cfg.stun.ignore_stun_error is set.

Change History

comment:1 Changed 7 years ago by bennylp

  • Status changed from new to closed
  • Resolution set to fixed

In 4205:

Fixed #1554: Assertion in ICE when STUN resolution yields a same address as one of the host candidate and there is only one host candidate exists (thanks Claudio De Angelis for the report)

Note: See TracTickets for help on using tickets.