Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#1470 closed defect (fixed)

Assertion in SIP transaction module init when restarting pjsua (thanks Roni Salfati for the report)

Reported by: nanang Owned by: bennylp
Priority: normal Milestone: release-1.14
Component: common Version: common
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description (last modified by nanang)

The assertion line:

Assertion failed: mod_tsx_layer.endpt==((void *)0),
file pjsip\src\pjsip\sip_transaction.c, line 436

This assertion doesn't always happen, however it is reproducible with a special test app containing a loop of: pjsua create+init+start, register, making call, call hold/unhold, call hangup, pjsua destroy. Supplying non-zero flag to the pjsua_destroy2() will lead to the assertion faster.

Change History (2)

comment:1 Changed 8 years ago by nanang

  • Resolution set to fixed
  • Status changed from new to closed

(In [3989]) Fix #1470: Make sure the transaction layer module is unloaded when SIP endpoint is destroyed, by rescheduling the unload (using SIP endpoint atexit callback) after unload failure due to any pending/undestroyed transaction.

comment:2 Changed 8 years ago by nanang

  • Description modified (diff)
Note: See TracTickets for help on using tickets.