Opened 8 years ago

Closed 7 years ago

#1428 closed defect (worksforme)

Review the case of no active media after SDP negotiation

Reported by: nanang Owned by: bennylp
Priority: normal Milestone: release-2.0-rc
Component: pjsua-lib Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

Even there is no matching codec in all media, pjsua will always respond 200/OK with all media disabled (no active media), this occurs in initial and subsequent offers.

Potential issue with such behaviour:

  • initial offer: incoming call callback is invoked, so user may answer the call but suddenly the call got hung up (by remote pjsua as it detects no active media).
  • subsequent offer: existing media streams may get updated to disabled mode (as the 200/OK response).

Note:

  • the behaviour of 1.x seems okay:
    • initial offer: auto reject with 488/500, so no incoming call callback is invoked.
    • subsequent offer: auto reject with 488/500, so existing the media session remain active.
  • need to check the behaviour when no active media is caused by all media are originally disabled in the offer?

Change History (2)

comment:1 Changed 7 years ago by ming

(In [3980]) Re #1428: Fix returning the correct error status when there is no active media.

comment:2 Changed 7 years ago by nanang

  • Resolution set to worksforme
  • Status changed from new to closed

Tested with audio only and audio+video for initial and subsequent offer/answer, seems to work fine (same behaviour with 1.x). It seems that other fixes also take part in fixing this issue, e.g: #r4052, 1423.

Note: See TracTickets for help on using tickets.