Opened 8 years ago

Closed 8 years ago

#1345 closed defect (fixed)

Assertion in codec operations caused by too small supplied buffer size.

Reported by: nanang Owned by: nanang
Priority: normal Milestone: release-2.0-alpha
Component: pjmedia Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description (last modified by nanang)

This is caused by a bug in samples-per-frame calculation PJMEDIA_SPF(). So applications that use PJMEDIA_SPF() for allocating buffer will get "too small buffer size" error or assertion from codec.

Change History (1)

comment:1 Changed 8 years ago by nanang

  • Description modified (diff)
  • Resolution set to fixed
  • Status changed from new to closed

In r3709: fixed samples-per-frame calculation formula bug in PJMEDIA_SPF().

Note: See TracTickets for help on using tickets.