Ticket #133 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

PUBLISH is rejected with 404 when REGISTER is challenged with 401/407 (thank Edward Tian)

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-0.5.10.2
Component: pjsua-lib Version: 0.5.10.1
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

When presence publication is enabled in pjsua account, pjsua-api sends PUBLISH overlapping with REGISTER, and when the REGISTER is challenged with 401/407, the PUBLISH request will be rejected with 404/Not Found.

Thanks Edward Tian for reporting the problem.

This is the duplicate of ticket #90 for the 0.5-stable branch.

Change History

comment:1 Changed 12 years ago by bennylp

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from PUBLISH is rejected with 404 because of timing mismatch with REGISTER to PUBLISH is rejected with 404 when REGISTER is challenged with 401/407

Fixed in r997.

comment:2 Changed 12 years ago by bennylp

  • Summary changed from PUBLISH is rejected with 404 when REGISTER is challenged with 401/407 to PUBLISH is rejected with 404 when REGISTER is challenged with 401/407 (thank Edward Tian)
Note: See TracTickets for help on using tickets.