Ticket #1228 (closed defect: duplicate)

Opened 7 years ago

Last modified 7 years ago

Long delay in iPhone initialization (thanks Guy Zelkha for the report)

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-1.10
Component: pjsua-lib Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

Delays up to several seconds are observed on certain iPhone systems.

Sample: iPhone OS-4.2.1/arm/iOS-SDK-4.1, no STUN.

 16:03:33.863   pjsua_core.c  pjsua version 1.8.10-trunk for iPhone OS-4.2.1/arm/iOS-SDK-4.1 initialized
 16:03:38.881   pjsua_core.c  SIP UDP socket reachable at 10.0.0.1:6000
 16:03:38.883    udp0xa4a600  SIP UDP transport started, published address is 10.0.0.1:6000
 16:03:43.898  pjsua_media.c  RTP socket reachable at 10.0.0.1:4000
 16:03:43.898  pjsua_media.c  RTCP socket reachable at 10.0.0.1:4001

Change History

comment:1 Changed 7 years ago by bennylp

  • Summary changed from Long delay in iPhone initialization to Long delay in iPhone initialization (thanks Guy Zelkha for the report)

comment:2 Changed 7 years ago by bennylp

  • Status changed from new to closed
  • Resolution set to duplicate

This is duplicate of ticket #1246

Note: See TracTickets for help on using tickets.