Opened 9 years ago

Closed 9 years ago

#1111 closed enhancement (fixed)

More work on automated testing for PJSIP

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-1.8
Component: unit-tests Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

This ticket continues the work on PJSIP's AutomatedTesting which was added in PJSIP 1.6 by ticket #1041.

Change History (20)

comment:1 Changed 9 years ago by bennylp

(In [3268]) Automated testing (re #1111): added -Wno-unused-label in CFLAGS for automated test

comment:2 Changed 9 years ago by bennylp

In r3269:

added script to run the test continuously

comment:3 Changed 9 years ago by bennylp

(In [3276]) Automated test (re #1111): small fix for make file based test scenarios

comment:4 Changed 9 years ago by bennylp

(In [3277]) Automated testing (re #1111): changed continuous monitoring interval from 1 to 5 minutes

comment:5 Changed 9 years ago by bennylp

(In [3278]) Automated test (re #1111): modified run_continuous.py script to also do Nightly build every day at 00:00 GMT

comment:6 Changed 9 years ago by bennylp

(In [3280]) Automated test (re #1111): added iPhone test scenario XML file

comment:7 Changed 9 years ago by bennylp

(In [3281]) Automated test (re #1111): modified configure.py to detect GNU host instead of always presenting vs (visual studio) as the default host

comment:8 Changed 9 years ago by bennylp

(In [3282]) Added README.txt in tests/automated directory (re #1111)

comment:9 Changed 9 years ago by bennylp

(In [3284]) More automated test (re #1111): added simple recvfrom test

comment:10 Changed 9 years ago by bennylp

(In [3285]) Automated test (re #1111): workaround for failed Speex PESQ test caused by progressive discard in the jitter buffer: disable the VAD for the Speex tests

comment:11 Changed 9 years ago by bennylp

(In [3286]) Automated test (re #1111): decrease Speex PESQ threshold as it is not always able to achieve that, possibly depending on the host activity

comment:12 Changed 9 years ago by nanang

(In [3287]) Automated test (re #1111): fixed test scenario scripts-recvfrom/301_timer_good_retry_after_422.py to use separate transaction for ACK (pattern matching was done to ACK, instead of INVITE).

comment:13 Changed 9 years ago by bennylp

(In [3289]) re #1111 (more on automated tests): added delay option in run_continuous.py to prevent more than one scripts from running simultaneously on a single host

comment:14 Changed 9 years ago by bennylp

(In [3290]) Re #1111 (more on automate test): small fix on the delay in run_continuous.py

comment:15 Changed 9 years ago by bennylp

(In [3291]) Re #1111 (more on automated tests): another fix on run_continuous.py

comment:16 Changed 9 years ago by bennylp

(In [3293]) re #1111 (more on automated tests): added prepare.xml scenario to rebuild the test scripts before performing the tests to make sure that they are up to date

comment:17 Changed 9 years ago by bennylp

(In [3294]) re ticket:1111 (more on automated test): added symbian target in prepare.xml@

comment:18 Changed 9 years ago by bennylp

(In [3297]) More on automated tests (re ticket:1111): added support for multiple Nokia/Symbian? SDK installed in one system

comment:19 Changed 9 years ago by bennylp

(In [3300]) More on automated tests (re ticket:1111): work on Visual Studio target, and added ability to disable tests in configure.py

comment:20 Changed 9 years ago by bennylp

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.