Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#990 closed defect (fixed)

S60 VAS audio device may fail to start properly in the first call.

Reported by: nanang Owned by: nanang
Priority: normal Milestone: release-1.5
Component: pjmedia-audiodev Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description (last modified by nanang)

The problem is occurred on few devices, e.g: E52 (S60 3rd ed FP2).

As the problem didn't occur in symsndtest, it seems that the problem was caused by pjsua querying VAS param before VAS completely initialized (async init).

Change History (2)

comment:1 Changed 10 years ago by nanang

  • Resolution set to fixed
  • Status changed from new to closed

In r3025:

  • Updated VAS stream start to be synchronous.
  • Fixed VAS formats enumeration in factory_init() to delete VAS factory instance.
  • Minor fix: compile warning on 5th edition: CPjAudioEngine has virtual member but no virtual destructor.

comment:2 Changed 10 years ago by nanang

  • Description modified (diff)
Note: See TracTickets for help on using tickets.