Ticket #979 (closed defect: fixed)

Opened 9 years ago

Last modified 9 years ago

Crash when printing Retry-After header (thanks Andrey Kovalenko for the report)

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-1.5
Component: pjsip Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

Crash when printing Retry-After header due to uninitialized "comment" field. To reproduce:

  pjsip_retry_after_hdr *hdr;
  char buf[80];

  hdr = pjsip_retry_after_hdr_create(pool, 5);
  pjsip_hdr_print_on(hdr, buf, sizeof(buf));

Change History

comment:1 Changed 9 years ago by bennylp

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in r2961

Note: See TracTickets for help on using tickets.