Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#946 closed defect (fixed)

Symbian kern-exec 0 in resolving IPv6 address.

Reported by: nanang Owned by: bennylp
Priority: normal Milestone: release-1.4
Component: pjlib Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

Found that kern-exec 0 is caused by access to RHostResolver instance for IPv6, while RHostResolver for IPv6 is also not opened/initialized when PJ_HAS_IPV6 is not set.

Change History (2)

comment:1 Changed 10 years ago by nanang

  • Resolution set to fixed
  • Status changed from new to closed

In r2888:

  • Fixed Symbian address resolver to have PJ_HAS_IPV6 check, so it will not try to resolve IPv6 address family when IPv6 is not enabled.

comment:2 Changed 10 years ago by bennylp

  • Milestone changed from release-1.4-QA to release-1.4
Note: See TracTickets for help on using tickets.