Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#890 closed defect (fixed)

pjlib-test failed on select() test Windows Vista multi-core

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-1.3
Component: unit-tests Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description (last modified by nanang)

Error log:

pjlib-test error:
 19:24:28.914 Running select_test()...
 19:24:28.916 ...Testing simple UDP select()
 19:24:28.917 ..ERROR(-70)

The select() returns immediately with *only* write-fdset is set (while the test also expects that read-fdset is set). So perhaps it is just that the system hasn't got time/context to deliver the packet, since select(), with write-fdset included, is called directly after sendto().

Experiments:

  • inserting pj_thread_sleep(1) between sendto() & select(): OK
  • inserting pj_thread_sleep(0) between sendto() & select(): failed
  • inserting PJ_LOG() between sendto() & select(): OK

The corresponding ticket for 1.0.x is #908

Change History (9)

comment:1 Changed 10 years ago by bennylp

  • Summary changed from pjlib-test failed on Windows Vista 64bit to pjlib-test failed on select() test Windows Vista 64bit

comment:2 Changed 10 years ago by nanang

  • Description modified (diff)

comment:3 Changed 10 years ago by bennylp

  • Summary changed from pjlib-test failed on select() test Windows Vista 64bit to pjlib-test failed on select() test Windows Vista multi-core

I can reproduce this with Visual Studio 6 | Debug on Windows Vista 32-bit dual core. Changing the title.

comment:4 Changed 10 years ago by bennylp

As additional info, the error only happens about 50% of the time.

comment:5 Changed 10 years ago by bennylp

  • Resolution set to fixed
  • Status changed from new to closed

In r2778:

  • Added pj_thread_sleep(10) before calling sleep(). Tried with other ways too but this seems to be appropriate for the test, as in the real application this shouldn't matter.

comment:6 Changed 10 years ago by bennylp

  • Milestone changed from release-1.3-QA to release-1.0.3

comment:7 Changed 10 years ago by bennylp

  • Milestone changed from release-1.0.3 to release-1.3

comment:8 Changed 10 years ago by nanang

  • Component changed from pjlib to unit-tests

comment:9 Changed 10 years ago by nanang

  • Description modified (diff)
Note: See TracTickets for help on using tickets.