Opened 10 years ago

Closed 10 years ago

#844 closed defect (fixed)

Assertion in on_rx_rtp(transport_udp.c) possibly due to race condition (thanks Peter Cai and Michael Broughton for the report)

Reported by: bennylp Owned by: nanang
Priority: normal Milestone: release-1.3
Component: pjmedia Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

See this post on PJSIP mailing list.

It is suspected that this may be caused by a race condition.

Attachments (1)

on_rx_rtp.patch (895 bytes) - added by bennylp 10 years ago.
Potential fix to protect the race condition. It should be safe from deadlock situation (see ticket #460), though still needs some more review

Download all attachments as: .zip

Change History (2)

Changed 10 years ago by bennylp

Potential fix to protect the race condition. It should be safe from deadlock situation (see ticket #460), though still needs some more review

comment:1 Changed 10 years ago by bennylp

  • Resolution set to fixed
  • Status changed from new to closed

on_rx_rtp.patch applied in r2753

Note: See TracTickets for help on using tickets.