Opened 10 years ago

Closed 10 years ago

#783 closed defect (worksforme)

Latency issue with Windows Mobile (thanks Johan Lantz for the report)

Reported by: bennylp Owned by: nanang
Priority: normal Milestone: release-1.4
Component: pjmedia Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

It has been reported that latency between two pjsip instances on Windows Mobile.

Change History (3)

comment:1 Changed 10 years ago by bennylp

  • Milestone changed from release-1.2 to release-1.3

comment:2 Changed 10 years ago by bennylp

  • Milestone changed from release-1.3 to release-1.4

comment:3 Changed 10 years ago by bennylp

  • Resolution set to worksforme
  • Status changed from new to closed

With the new pjsystest application, so far we concluded that this is caused by the latency in the WM audio itself. On some devices the audio loopback latency can go as high as 550 ms and average of 470 ms, while on others it can be as low as 155/145 ms max/avg audio loopback latency.

This does not seem to be related to the device types as it can happen on both WM6 Professional and Standard devices, but it seems to be more related to the device's performance/CPU, although some devices with the same CPU Mhz may have different result.

Some devices with high latency:

  • BENQ E72 (WM6 Std, 270 Mhz TI OMAP V1030 CPU)
  • HTC P3600 (WM5 Pro, 400 MHz Samsung SC32442 CPU)*
  • HTC Pro (Qualcomm® MSM7201A™ 528 MHz)*

Some devices with good latency:

  • Samsung SGH-i780 (WM6 Pro, 624 MHz Marvell PXA310 CPU)
  • O2 XDA Zest (WM6.1 Pro, 624 Mhz Marvell PXA930 CPU)
  • Intermec CN3 (WM5 PPC Phone Ed, 520 Mhz Intel XScale PXA270 CPU)*

(*: based on user's reports)

Closing the ticket for now.

Note: See TracTickets for help on using tickets.