Opened 10 years ago

Closed 10 years ago

#773 closed defect (fixed)

Miscellaneous fixes

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-1.0.3
Component: common Version: 1.0.x
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description (last modified by bennylp)

This is duplicate of ticket #772 and #838 for 1.0 branch. It is a placeholder for miscellaneous fixes across all projects in 1.0 branch.

Change History (3)

comment:1 Changed 10 years ago by bennylp

  • Description modified (diff)

comment:2 Changed 10 years ago by bennylp

In r2818: backported changes from #772:

  • from r2566: bug in pjsua application when reading the URL from the buddy list, causing corrupt/invalid URI to be returned. Thanks Robert Cichielo for the report.
  • from r2577: Updated floating point version of math statistic to return the rounded mean value.
  • from r2586: Updated stream_destroy() to call jbuf_destroy().
  • from r2604: Changed var 'test' (in sdp_neg_test.c) from a global var to static var, since there was naming conflict with libg7221codec.

comment:3 Changed 10 years ago by bennylp

  • Resolution set to fixed
  • Status changed from new to closed

In r2819: backported changes from #838:

  • from r2749: protect pj_strdup() for case when source and destination string are the same pointer. Without this, destination string will contain garbage value.
Note: See TracTickets for help on using tickets.