Ticket #74 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

Enlarge RX_BUF_COUNT in conference bridge to 32

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-0.5.10
Component: pjmedia Version: 0.5.9
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

ChenHuan? <chenhuan @ sict.ac.cn> reported that enlarging RX_BUF_COUNT to 32 fixes the stutter problem on Windows Mobile, even when using small ptime (10 or 20ms).

Change History

comment:1 Changed 12 years ago by bennylp

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in r899:

Added PJMEDIA_SOUND_BUFFER_COUNT (default=32) as a global setting in PJMEDIA to control number of sound buffers. Used by conference.c, splitcomb.c, and dsound.c.

comment:2 Changed 12 years ago by federico.omoto@…

I can confirm that this also fix the stutter problem on Windows XP too!

comment:3 Changed 12 years ago by bennylp

r970: reduce again the default sound buffers count from 32 to 16 because this causes too much delay.

Note: See TracTickets for help on using tickets.