Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#648 closed defect (fixed)

Build problem on Visual Studio 6 when IPv6 support is disabled and IPv6 kit is not installed (thanks Massimiliano Montevecchi for the report)

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-1.0-rc4
Component: pjlib Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

Build error:

Compiling...

addr_resolv_sock.c

C:\Programmi\Microsoft Visual Studio\VC98\INCLUDE\qos.h(236) : warning C4201: nonstandard extension used : nameless struct/union

C:\Programmi\Microsoft Visual Studio\VC98\INCLUDE\qos.h(463) : warning C4201: nonstandard extension used : nameless struct/union

C:\ANTS-Development\IMS\pjproject-1.0-rc3\pjlib\src\pj\addr_resolv_sock.c(64) : error C2079: 'hint' uses undefined struct 'addrinfo'

C:\ANTS-Development\IMS\pjproject-1.0-rc3\pjlib\src\pj\addr_resolv_sock.c(97) : error C2224: left of '.ai_family' must have struct/union type

C:\ANTS-Development\IMS\pjproject-1.0-rc3\pjlib\src\pj\addr_resolv_sock.c(99) : warning C4013: 'getaddrinfo' undefined; assuming extern returning int

This seems to have been caused by ticket #629

Change History (3)

comment:1 Changed 11 years ago by bennylp

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r2327:

  • incorrect muticast related socket constant names causing link error when these constants are used,
  • missing ws2tcpip.h include causing build error on Mingw, and
  • error building on Visual Studio 6 due to PJ_SOCK_HAS_GETADDRINFO being declared accidentally.

comment:2 Changed 11 years ago by bennylp

  • Milestone changed from release-1.0 to release-1.0-rc4

comment:3 Changed 11 years ago by bennylp

More in r2331:

  • build error on VS6 with built-in SDK and on PocketPC 2003 SDK since they don't have multicast related socket options
Note: See TracTickets for help on using tickets.