Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#638 closed enhancement (fixed)

Update jitter buffer to avoid/reduce such case of shrinking and underflow occuring one after another.

Reported by: nanang Owned by: nanang
Priority: normal Milestone: release-1.0-rc3
Component: pjmedia Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description (last modified by nanang)

Proposed solutions:

  1. Shrinking to be based on recent maximum burst level. This will make jitter buffer shrinking a bit less aggressive. Currently shrinking is done based on current burst level (presented by jb_prefetch).
  2. Reenable prefetch buffering. This should be able to be configured in run-time, e.g: setting initial-prefetch > 0 will make this feature enabled.

Change History (8)

comment:1 Changed 11 years ago by nanang

  • Description modified (diff)

comment:2 Changed 11 years ago by nanang

  • Resolution set to fixed
  • Status changed from new to closed

In r2310:

  • Jitter buffer shrinking is done based on max_hist_level (recent maximum burst level).
  • Updated jitter buffer to maintain max_hist_level instead of resetting it each time current level updated.
  • Updated default jitter buffer size in stream.c from 360ms to 500ms to accomodate more burst level.

comment:3 Changed 11 years ago by nanang

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:4 Changed 11 years ago by nanang

  • Description modified (diff)
  • Summary changed from Update jitter buffer shrinking to be based on recent maximum burst level. to Update jitter buffer to avoid/reduce such case of shrinking and underflow occuring one after another.

comment:5 Changed 11 years ago by nanang

In r2317: Reenable prefetch buffering via initial prefetch setting (set 0 to disable, otherwise to enable).

comment:6 Changed 11 years ago by bennylp

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:7 Changed 11 years ago by nanang

r2318: Cleaned up compilation warning in jbuf.

comment:8 Changed 11 years ago by nanang

r2321: Fixed assertion caused by prefetch > min_prefetch (thanks Michael Bradley Jr for the report).

Note: See TracTickets for help on using tickets.