Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#623 closed defect (fixed)

Assertion when receiving SUBSCRIBE with non presence event (thanks Lucas Rosa Galêgo for the report)

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-1.0-rc3
Component: pjsua-lib Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description (last modified by bennylp)

An assertion will be triggered when pjsua receives incoming SUBSCRIBE with Event header containing value which we don't support (we only support "presence" at the moment). This happens when PJSUA-LIB calls pjsip_dlg_terminate(), since a transaction is still active when the dialog is terminated.

Thanks Lucas Rosa Galêgo for the report.

Change History (2)

comment:1 Changed 11 years ago by bennylp

  • Description modified (diff)
  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r2273:

  • error in creating server subscription will be responded with the appropriate error code (489/Bad Event in this case), and dialog will be terminated properly.

comment:2 Changed 11 years ago by bennylp

Also added a script in the unit test to reproduce it in the changeset above.

Note: See TracTickets for help on using tickets.