Ticket #618 (closed defect: invalid)

Opened 10 years ago

Last modified 10 years ago

Bad tone quality generated by the tone generator when floating point is disabled

Reported by: bennylp Owned by: nanang
Priority: normal Milestone: Known-Issues
Component: pjmedia Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description (last modified by bennylp) (diff)

Issues with the tone generator:

  • The sine approximation algorithm especially for the fixed point version is not good enough, causing aliasing frequencies to occur
  • The volume perhaps can be made louder
  • The volume is different between float and fixed point version
  • The tonegen should attempt to create a full period of wave signal, slightly truncating or appending some samples as necessary.

Change History

comment:1 follow-up: ↓ 3 Changed 10 years ago by bennylp

Issues with the tone generator:

  • The sine approximation algorithm is not good enough, causing aliasing frequencies to occur
  • The volume perhaps can be made louder
  • The volume is different between float and fixed point version
  • The tonegen should attempt to create a full period of wave signal, slightly truncating or appending some samples as necessary.

comment:2 Changed 10 years ago by bennylp

  • Description modified (diff)

comment:3 in reply to: ↑ 1 Changed 10 years ago by bennylp

  • Status changed from new to closed
  • Resolution set to invalid
  • Milestone changed from release-1.0-rc3 to Known-Issues

Wrong comment above (

comment:4 Changed 10 years ago by bennylp

This is duplicate of ticket #619

Note: See TracTickets for help on using tickets.