Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#591 closed defect (fixed)

Assertion failure in ICE session (thanks Pedro Gonçalves for the report)

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-1.0-rc1
Component: pjnath Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description (last modified by bennylp)

Symptom:

Assertion pj_assert(tdata == check->tdata) in on_stun_request_complete() function in ice_session.c:1771, because STUN client transaction completes while the connectivity check doesn't have record for this transaction.

Attachments (1)

tdata_assert_error.log (89.9 KB) - added by bennylp 11 years ago.
The log file

Download all attachments as: .zip

Change History (4)

comment:1 follow-up: Changed 11 years ago by bennylp

  • Description modified (diff)
  • Resolution set to fixed
  • Status changed from new to closed

Fixed in 2202:

  • the assertion is caused by race condition in pj_ice_sess_start_check(). It happens when the function is running the pending triggered checks in ice->early_check list while at the same time an incoming check arrives and a triggered check is performed for the same check.

comment:2 in reply to: ↑ 1 Changed 11 years ago by bennylp

Replying to bennylp:

Fixed in 2202:

This should say: "Fixed in r2202"

Changed 11 years ago by bennylp

The log file

comment:3 Changed 11 years ago by bennylp

More in r2206

Note: See TracTickets for help on using tickets.