Ticket #558 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

Memory leak in SRTP

Reported by: bennylp Owned by: nanang
Priority: normal Milestone: release-1.0-rc1
Component: pjmedia Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

The libSRTP's srtp_init() function allocates some variables which are not freed, causing memory leak.

The solution is to add srtp_deinit() function and register this with pj_atexit().

Change History

comment:1 Changed 10 years ago by nanang

In r2141: Fixed memory leak caused by cipher_type_self_test().

comment:2 Changed 10 years ago by nanang

  • Status changed from new to closed
  • Resolution set to fixed

comment:3 Changed 10 years ago by nanang

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:4 Changed 10 years ago by nanang

In r2353: Added srtp_deinit() function and registered this with pj_atexit().

comment:5 Changed 10 years ago by nanang

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.