Ticket #542 (closed defect: fixed)

Opened 9 years ago

Last modified 9 years ago

Enable setting sound device latency at runtime.

Reported by: nanang Owned by: nanang
Priority: normal Milestone: release-0.9.0
Component: pjmedia Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description (last modified by nanang) (diff)

Some of unstable audio problems seem to be caused by latency set too low (current setting is PA's default low latency). Since the ideal sound device latency setting depends on many parameters (e.g: OS, hardware/sound card, CPU load), this setting should be able to be set at runtime, and default setting should be set as 'safe' as possible yet minimum.

Change History

comment:1 Changed 9 years ago by nanang

In r2007: added new API and macro for sound device latency settings, also added new param for this in pjsua."

comment:2 Changed 9 years ago by nanang

  • Status changed from new to closed
  • Resolution set to fixed

In r2010: updated dsound.c to adapt with latency setting

comment:3 Changed 9 years ago by nanang

  • Description modified (diff)

r2048: Updated default capture latency.

Note: See TracTickets for help on using tickets.