Ticket #521 (closed defect: fixed)

Opened 9 years ago

Last modified 9 years ago

Duplicate Authorization header when PJSIP is configured to send empty Authorization header (thanks Roland Klabunde)

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-0.9.0
Component: pjsip Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

In IMS mode (--use-ims option in pjsua), PJSIP is configured to send an empty Authorization header which can be used to force server to use MD5 authentication. Unfortunately this will cause subsequent authentication retry to include duplicate Authorization headers as the old one was not removed.

Change History

comment:1 Changed 9 years ago by bennylp

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in r1906:

  • this was caused by the Authorization header being created as a generic string header rather than a real Authorization header, causing the removal code to fail to find the empty Authorization header.
Note: See TracTickets for help on using tickets.