Ticket #517 (closed defect: fixed)

Opened 9 years ago

Last modified 9 years ago

Invalid argument error when binding media transport on MacOS X (thanks Daniel Mikusa)

Reported by: bennylp Owned by: nanang
Priority: normal Milestone: release-0.9.0
Component: pjmedia Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

Running simpleua.c and siprtp.c samples on MacOS X give the following error:

 00:07:47.017     simpleua.c Unable to create media transport: Invalid argument [code=120022]

This was caused by invalid value in the address length argument given to pj_sock_bind().

Change History

comment:1 Changed 9 years ago by bennylp

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in r1899

Note: See TracTickets for help on using tickets.