Ticket #458 (closed defect: fixed)

Opened 9 years ago

Last modified 10 months ago

PJ_ERESOLVE error in Windows Mobile

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-0.9.0
Component: common Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Attachments

ticket 458.patch (1.2 KB) - added by nanang 9 years ago.

Change History

Changed 9 years ago by nanang

comment:1 Changed 9 years ago by nanang

No network connection case

After performed some tests trying to reproduce the problem, I caught the PJ_ERESOLVE error only when no network connection is active, other condition resulted fine.

Tests performed:

  • call with and without registration.
  • call with and without username in the URI.
  • registration with IP address and hostname.

The problem is rooted from failure of gethostbyname(IP_ADDR) when no network connection is active. So the problem should be fixed by checking if the input is already IP address, pj_getaddrinfo() skips the pj_gethostbyname.

Attachment 'ticket 458.patch' contains:

  • Added check if param 'nodename' for pj_getaddrinfo() is already IP address
  • Added check if iteration interface gives no result, return PJ_ENOTFOUND

comment:2 Changed 9 years ago by bennylp

Patch committed in:

r1743:

  • enum_interface() should return non-PJ_SUCCESS if it does not find any interface

r1744:

  • pj_getaddrinfo() should return success if IP address is given

comment:3 Changed 9 years ago by bennylp

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

comment:4 Changed 10 months ago by nanang

In 5319:

Fix #1925: pj_getaddrinfo() should invoke getaddrinfo() even when IP address is inputted, except on Windows Mobile platforms (see #458).

Note: See TracTickets for help on using tickets.