Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#427 closed defect (fixed)

Conference bridge doesn't handle NONE frame (thanks Daniel Braun)

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-0.9.0
Component: pjmedia Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

The conference bridge doesn't handle PJMEDIA_FRAME_TYPE_NONE emitted from some media ports (such as tone generator), causing it to process frame buffer that's not initialized. This could cause errors such as noise being generated, or in some cases, even echoes.

Thanks Daniel Braun for reporting this.

Change History (2)

comment:1 Changed 12 years ago by bennylp

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r1623

comment:2 Changed 11 years ago by bennylp

In r1637:

  • Fixed bug caused by this ticket: frame type not properly initialized to PJMEDIA_FRAME_TYPE_AUDIO, causing audio frames to be dropped in the conference bridge (thanks P.J. Cast)
Note: See TracTickets for help on using tickets.