Ticket #423 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

Client registration (pjsip_regc) doesn't obey explicit transport selection (thanks Hitesh)

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-0.9.0
Component: pjsip Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

When pjsip_regc is configured to use explicit transport (with pjsip_regc_set_transport()), it still sends request using default transport.

Change History

comment:1 Changed 10 years ago by bennylp

  • Status changed from new to closed
  • Resolution set to fixed

This was caused by the pjsip_regc doesn't make use of tp_sel at all! Fixed in r1593.

Note: See TracTickets for help on using tickets.