Ticket #401 (closed defect: fixed)

Opened 9 years ago

Last modified 9 years ago

Unable to register when account URI contains display name

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-0.8.0
Component: pjsip Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

When account URI contains display name, pjsip incorrectly interpret successful REGISTER response as unregistration response.

Change History

comment:1 Changed 9 years ago by bennylp

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in r1518:

  • the error was caused by the proxy (a well known open source SIP proxy) didn't put the display name in the Contact header of 200 response, causing Contact header comparison to fail (it detected that the Contact header is different).
  • the solution was to ignore the display name part when performing URI comparison.
Note: See TracTickets for help on using tickets.