Ticket #369 (closed defect: duplicate)

Opened 10 years ago

Last modified 10 years ago

ICE negotiation fails after endpoint has been idle for long time

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-0.8.0
Component: pjnath Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description (last modified by bennylp) (diff)

Ravin Suri reported:

I have seen some instances where after many hours of running pjsua in an idle mode, it will not be able to make calls due to ICE negotiation failing. On quitting pjsua and restarting it, a call to the same destinations is successful.

This is the sequence of steps:

  • start pjsua on both ends
  • make a call from one to another -- this works fine, ICE neg succeeds and call is ok.
  • hang up call after a few minutes
  • let the pjsua's keep running for say, 8 hours
  • try to make the same call again to the other pjsua
  • ICE negotiation fails
  • shut and restart caller pjsua
  • call other pjsua
  • ICE works and call is made successfully

Change History

comment:1 Changed 10 years ago by bennylp

  • Description modified (diff)

comment:2 Changed 10 years ago by bennylp

  • Status changed from new to closed
  • Resolution set to duplicate

This is duplicate of ticket #372

Note: See TracTickets for help on using tickets.