Ticket #35 (closed defect: invalid)

Opened 12 years ago

Last modified 12 years ago

Unregistration unregisteres ALL Contacts

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-0.5.10
Component: pjsip Version: 0.5.9
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

Currently the unregistration function in PJSIP client registration (pjsip_regc_unregister()) sends REGISTER with Expires=0 for all contacts including those that are registered by other endpoints (because Contact header is set to "*"). This is not the correct behavior since it prevents more than one AOR to be registered.

Change History

comment:1 Changed 12 years ago by bennylp

  • Status changed from new to closed
  • Resolution set to invalid

This is duplicate of ticket #36.

Note: See TracTickets for help on using tickets.